Sunday, August 16, 2009

In the name of science

Today was a fun day with the EV. It's not often you have multiple components laying around to get to really test things. You do your research and buy components, then just hope for the best. Not today!
Today a group of friends brought over two of their Kelley controllers for some head-to-head comparisons against each other and my Curtis 1231C. The two Kelley controllers were a 144v 500 amp model, and a 120v 800 amp model.
We monitored pack side voltage and amps, as well as motor side voltage and amps. Sadly we didn't have a computer tracking the information for a nice graph later but the results were clear enough.
The tests we did, to try and be as accurate as possible, was a 2nd gear take off to 30mph. This requires no shifting and gives the motor a long low RPM scenario so we can measure amps.
We tried to do as little modification as possible to swap controllers so things didn't need to look good. There are a lot duplicate wires, duct tape and bailing wire. Not to mention the cardboard electric isolators and bungee cord hood tie downs.
Please don't let your final EV project look like this! :)


The Kelley 144v 500 amp controller was rather sad in my opinion. The highest recorded motor side output was 320 amps. Even in first gear that car felt like it had no power. We tried the "torque" and "speed" settings of the controller, but it didn't change much. The 0-30 test took 15 seconds on average!
Next the Kelley 120v 800 amp controller. Surprisingly this is in the exact same enclosure as the 500 amp version. We removed seven of my LiFePO4 cells to drop the pack voltage within spec of the controller. I bit of an apples to oranges test, but we had no choice here. Maximum recorded amps was 640 with a 0-30 time of 8 seconds. Much better, but where is the 800 amps this controller is claiming? Perhaps if you could record with enough accuracy you'd see this number for a fraction of a second. Even the 600 amps is gone in less than a second. From the instant you see 600+ amps, they start dropping fast and within seconds you're looking at 400 amps and then a slower drop off rate. I admit though, out of the hole the bottom end torque felt really good, it just didn't last long.
Technically we tested the Curtis first since it was in the car, but afterwards we tested it again to track a few points better after we understood a few things. The Curtis surprised me as we saw 535 amps at peak. The interesting point was this didn't fall down nearly as quick as the two Kelley's. We counted a full 5 seconds before we even fell below 500. Although the Curtis and Kelley 800 had nearly the same 0-30 of 7-8 seconds the main difference was that the Kelley started off very hard but with it quickly dropping amps it was hard to get to 30 mph in the end. The Curtis on the other hand pulled hard and consistently right past 30 mph.
Pack side measurements weren't really worth mentioning as they were consistant and reflected the performance seen on the motor side. None of the controllers were able to push the pack amperage above 500 amps. Even at the lowest RPM to get high motor side amps, the pack was only seeing 250 or around there during that. This opens my mind now to installing a higher end controller knowing I can really increase my low end without jeopardizing the pack.

3 comments:

Yamez4u said...

I would love to see you opinion of this guy:
http://www.evcomponents.com/ProductDetails.asp?ProductCode=SYNKRO

Brian said...

I've seen this one on their site. I wish I had it play with as well.

It's a brand new controller, so it's going to be hard to find anybody who has done any performance analysis on it.

David Harrington said...

I have the new Synkro on order and hope to get it by October to replace my teeny weeny Kelly. The I can do some performance tests.